Neato Support

What are the system requirements for using Connected-Series Robots with the Neato app?

This information is related to:

  • Botvac D3 Connected
  • Botvac D4 Connected
  • Botvac D5 Connected
  • Botvac D6 Connected
  • Botvac D7 Connected

 

 Internet Connection

 

  • An Internet connection is required to run the robot in connected mode.
  • An Internet connection is required to use the Neato app.
  • Basic high internet connection speeds.

 Router / Extenders

 

  • Neato Botvac Connected-Series robots work with 2.4GHz networks
  • Neato Botvac D7 Connected robots are also compatible with 5GHz Wi-Fi networks.

Devices Supported

 

 Apple

  • Supported Software:
    • iOS 10.2 or newer

  • Supported Hardware:
    • Apple iPhone 5 and newer
    • Apple iPad4 and newer
    • Apple iPod Touch 6th gen
    • Apple iPad Minis and newer
    • Note: Neato app is not optimized for tablets

 


 

Android 

  • Supported Software:
    • Android 4.1 and newer

  • Supported Hardware:
    • Xlarge screens (at least 960dp x 720dp)
    • Large screens (at least 640dp x 480dp)
    • Normal screens (at least 470dp x 320dp)

  • Not Supported:
    • Small screens at or lower than (426dp x 320dp) or lower

Network Security

 

  • WPA and WPA2 using TKIP, PSK, AES/CCMP encryption.

  • WEP EAP (Enterprise Authentication Protocol) are not supported

 

Wi-Fi Channels

 

  • For 2.4 GHz networks (Botvac D3 - D7 Connected)
  • For 5 GHz networks Botvac D7 Connected



Top Articles

Related Articles



Have a question? If you can't find the answer to your question, you can contact us. We are here and happy to help. Contact Us